IPC Software upgrade through mini-Installer

To perform this manual upgrade we provide a mini-installer (executable file). This file must be deployed and run on each host PC where IPC-2 v 2.x.x is installed. The default installation location selected by installer would be C:\YESEFT, choose a different location if EVT is installed in any other directory.

To download the mini-installer, please contact the WPT support team for the dropbox link. Send an e-mail tototal.support@worldpay.comto get the password protected package.

Running the mini-installer in Attended mode

  1. Start the mini-installer file on the host PC.

  2. From the welcome screen click Next.

  3. Click Finish after the setup is done to exit.

  4. After this process is successfully completed, the client software will be updated to the new IPC version. The version can be can checked by running YESEFTConfig.bat, or by inspecting the contents of YESEFT/version.txt.

In the YESEFTConfig utility, the version is displayed on the top of the window.

Running the mini-installer in Silent mode (Windows)

  1. Open up the Command window and change directory to where the mini-installer is located.

  2. Execute the installer using followed -q switch will run the mini-installer in background.

Example: C:>IPC2-102_to_IPC2-229_Upgrader.exe –q

Note: Once EVT has been upgraded to IPC v1.1.1 or above it will fail to initialise for contactless operation with an iPP350 PED of firmware version lower than RAM 0973 where iPP350-CTLS pin-pad has been selected in YESEFTConfig.

You'll need to update firmware, seePED firmware upgrade process. If the firmware upgrade of the PED does not succeed, it is compulsory to either replace the PED or roll IPC back to the original version.

We also provide an option of upgrading software from EVT v 3.4.x.x to IPC v2.1.8 (minimum EVT version required is 3.4.1.9) and Ingenico PED firmware from RAM 0901 to RAM 1606 using a script. The script uses both of the above mentioned mini-installers to upgrade software and pre-placed firmware packages to upgrade PED firmware.